Download Latest Bugfix Build

Besorge Dir das neueste Bugfix-Build der freigegebenen Version von Allegra.

Diese Webseite nutzt Cookies für Funktions-, Komfort- und Statistikzwecke. Indem Sie hier fortfahren, stimmen Sie dieser Verwendung zu.

Info

Installer-Anleitung

Um die Software neu zu installieren oder eine frühere per Installer installierte Version zu aktualisieren führe den Installer als Administrator aus (rechte Maustaste im Explorer, "Als Administrator ausführen").

Systeman­forderungen

Betriebssystem: ab Windows 7, Windows Server 2012
Hauptspeicher: min. 2 Gbyte
Freier Festplattenspeicher: min. 1 Gbyte
Java VM: Oracle oder OpenJDK 1.8 oder höher

Service-Desk-Modul

Das Service Desk-Modul wird als ZIP-Datei zur Verfügung gestellt. Diese musst Du auf Deinem existierenden Webserver in einem Verzeichnis entpacken, das über eine URL zugänglich ist. Der Webserver muss PHP-Code ausführen können.

Kopiere die Datei "config-sample.php" nach "config.php" und passe darin die URL für die REST-Schnittstelle Deines Allegra-Servers an. Kopiere die Dateien "footer-sample.php", "header-sample.php" und "custom-sample.php" in die entsprechenden Dateien ohne "-sample" und nimm darin ggfs. Anpassungen vor.

Update des Service-Desk-Moduls

Für ein Update des Moduls gehe in das Verzeichnis, in das Du das Modul installiert hattest. Führe darin die Datei "update.php" aus.

 

Installation auf Ubuntu 18.04

Du kannst in wenigen Minuten ein voll funktionsfähiges System auf einem Ubuntu 18.04 LTS mit Postgres-Datenbank installieren:

  • Lade das Installationsskript herunter und führe es unter Angabe des gewünschten Kontext-Namens aus
  • Beispiel: sudo ./install.sh allegra
  • Kurz darauf kannst du de Installation unter http://yourdomain.com/allegra erreichen.

Bitte beachte, dass der Port 80 frei sein muss und sich noch kein Apache Tomcat und Postgres auf dem System befinden darf. Das Skript eignet sich deshalb besonders für eine Cloud-Installation.

Manuelle Installation

Zunächst installiere eine entsprechende Ablaufumgebung:

  • Installiere Java JDK 8.0 oder neuer.
  • Installiere einen Apache Tomcat 9.0 oder neuer als Applikationsserver
  • Installiere einen MySQL, Oracle, DB2, Postgres, Firebird oder MS SQL Server Datenbankserver

Die genaue Vorgehensweise zur Installation und zum Upgrade ist im Installationshandbuch beschrieben, das du im Dokumentationsbereich findest.

Systeman­forderungen

Betriebssystem: Windows ab 7, Server 2012, Linux, OS/X
Hauptspeicher: min. 2 Gbyte
Freier Festplattenspeicher: min. 1 Gbyte
Java VM: Oracle  oder OpenJDK 1.8 oder höher